Lattice Diamond软件是否支持VHDL 2008?

目前的Lattice Diamond软件不支持VHDL 2008.用户可以使用下面的建议工作

工作1:

  1. 在独立模式下打开Synplify。
  2. 创建一个新项目,将2008-vhdl文件添加到项目中
  3. 在Synpylfy Pro菜单中,单击< Options>
  4. - >
  5. 选择<配置>
  6. <配置VHDL编译器> - >

选择< VHDL< vhdl>

标签 - >

选择< VHDL 2008>

< / VHDL>< /配置>

现在,编译(F7),然后单击“运行”。 。Synplify将合成您的代码并发出edn文件(* .edn)。 。现在,在Diamond中创建一个新项目,并将* .edn(从步骤4获得)作为输入/源文件。 。Diamond将跳过Synthesize,并将从“Translate Design”过程运行。 。工作2: 。在strategy-> Synplify Pro->命令行选项中添加set_option -vhdl2008。 。但是,Lattice Diamond前端工具不支持VHDL2008,类似于显示,生成层次结构等。 。目前支持VHDL2008的计划是在Lattice Diamond Software 3.2中。
编辑 重设标签(回车键确认) 标为违禁 关闭 合并 删除

提问于 2018-07-27 11:59:15 +0800

这个帖子被标记为一个社区wiki

这个帖子是一个wiki(维基). 任何一个积分 >500的人都可以完善它