LogiCORE SPI-4.2(POS-PHY L4)v8.4 - 需要补丁来解决SPI4.2源核心问题

问题描述

需要以下补丁来解决SPI-4.2 v8.4源核心问题。该补丁将解决以下两个问题:

1. CR 453077:源核心在发送写入FIFO的最后一个数据包的最后一个信用和EOP时出现问题。当SrcBurstMode = 1,SrcBurstLen大于256时发生故障

2. CR 453079:断言源溢出信号(SrcFFOverflow_n),而不将Almost Full信号(SrcFFAlmostFull_n)置为有效。当SrcBurstMode = 1,SrcBurstLen大于256且SrcAFThresAssert小于SrcBurstLen时,会发生故障。

注意:这两个问题也存在于:

SPI-4.2 v 8.2于2006年10月与ISE 8.2i IP Update 2一起发布。

SPI-4.2 v 8.3于2007年2月与ISE 9.1i IP Update 1一起发布。

如果您当前使用的是SPI-4.2的v8.2或v8.3,请更新到v8.4核心并应用补丁。

如果升级到SPI-4.2的v8.5,则会解决这两个问题。因此,此补丁不是必需的。

受影响的核心是SPI-4.2 v8.2,v8.3和v8.4,在XCO文件中具有以下设置。

CSET burst_mode = Complete_Burst

CSET burst_size_in_credits = 256和更高

CSET source_almost_full_assert = 32

可以在包装器文件中更改这些设置。查找以下设置:

SrcBurstLen = 256或更高

SrcBurstMode = 1

SrcAFThresAssert =小于SrcBurstLen

解决/修复方法

要解决这两个问题,请安装spi-42_v8_4_rev1补丁。

注意:安装SP3和IP Update#1或#2后,必须在ISE 9.2i上应用此修补程序。

建议的安装顺序如下:

- ISE 9.2i

- Service Pack 3(适用于ISE 9.2i)

- IP更新#1或#2(适用于ISE 9.2i)

- SPI-4.2 v8.4补丁#1

下载SPI-4.2补丁:

http://www.xilinx.com/txpatches/pub/swhelp/coregen/spi42_v8_4_rev1.zip (适用于PC)

http://www.xilinx.com/txpatches/pub/swhelp/coregen/spi42_v8_4_rev1.tar.gz (适用于Linux或UNIX)

要安装修补程序,请按照下列步骤操作:

1.关闭CORE Generator和其他ISE应用程序。

2.将“.zip”或“.tar.gz”存档的内容解压缩到Xilinx ISE安装的根目录(即C:\ Xilinx)。选择允许提取程序覆盖所有现有文件并维护存档中预定义的目录结构的选项。

要确定Xilinx安装目录,请在命令提示符处输入以下内容:

对于PC:

“echo%Xilinx%”

对于UNIX或Linux:

“echo $ Xilinx”

3.安装补丁后,在CORE Generator中重新生成LogiCORE SPI-4.2 v8.4内核。生成的核心和支持文件将包含上述修复程序。版本信息将包含“v8.4 Rev 1中的错误修复”部分,其中列出了此修补程序中修复的问题。

编辑 重设标签(回车键确认) 标为违禁 关闭 合并 删除

提问于 2018-08-18 20:46:20 +0800

这个帖子被标记为一个社区wiki

这个帖子是一个wiki(维基). 任何一个积分 >500的人都可以完善它