错误:“关联列表错误:默认关联元件与正式LPM_FILE不兼容”(LPM_RAM_DP,VHDL,MAX +PLUS®II版本9.2x)

此错误已在MAX + PLUS II软件9.3及更高版本中得到修复。

如果使用LPM_COMPONENTS包在VHDL设计文件中实例化LPM_RAM_DP组件并且未指定LPM_FILE参数的值,则会收到此错误消息。

LPM_COMPONENTS包文件( lpm_pack.vhd )中LPM_RAM_DP的组件声明未向LPM_FILE参数分配默认值。因此,如果在代码中实例化此函数时未向LPM_FILE参数赋值,则会收到上述错误。

此软件包文件的更正版本lpm_pack.vhd (文件名仅包含小写字符)已发布到/ outgoing目录中的Altera FTP站点。 MAX + PLUS II软件附带的当前lpm_pack.vhd文件应该替换为这个新文件。

要替换此文件,请执行以下步骤:

  1. 关闭相应库目录(< MAX + PLUS II目录 > \ VHDL87 \ lpm或< MAX + PLUS II目录 > \ VHDL93 \ lpm )中所有文件的只读属性。
  2. 使用新的包覆文件覆盖相应VHDL库目录中的现有包文件。
  3. 在MAX + PLUS II软件中编译包文件。
  4. 重新启用目录中所有文件的只读属性。
编辑 重设标签(回车键确认) 标为违禁 关闭 合并 删除

提问于 2018-08-06 16:46:56 +0800

这个帖子被标记为一个社区wiki

这个帖子是一个wiki(维基). 任何一个积分 >500的人都可以完善它