DDR和DDR2 SDRAM控制器MegaCore®功能版本3.3.0是否支持SOPC Builder工具中的Stratix®GX器件?

DDR和DDR2 SDRAM控制器MegaCore功能支持Stratix GX器件。但是,当在针对Stratix GX系列的SOPC Builder系统中实例化DDR和DDR2 SDRAM控制器内核时,您将收到一条错误消息,指示DDR和DDR2 SDRAM控制器MegaCore不支持Stratix GX系列。您可以通过修改DDR和DDR2 SDRAM控制器MegaCore SOPC Builder组件的class.ptf文件来解决此问题。为此,请确保关闭SOPC Builder工具,然后执行以下步骤:
  1. 浏览到<DDR和DDR2 SDRAM控制器MegaCore安装目录> / lib / sopc_builder / ddr_sdram_component文件夹并打开class.ptf文件
  2. 在class.ptf文件中搜索以下行:

    Required_Device_Family =“STRATIXII,STRATIX,CYCLONEII,CYCLONE”;

  3. 将此行修改为:

    Required_Device_Family =“STRATIXII,STRATIX,STRATIXGX,CYCLONEII,CYCLONE”;

现在,您可以重新打开SOPC Builder工具并实例化DDR和DDR2 SDRAM控制器内核。

编辑 重设标签(回车键确认) 标为违禁 关闭 合并 删除

提问于 2018-08-04 14:24:27 +0800

这个帖子被标记为一个社区wiki

这个帖子是一个wiki(维基). 任何一个积分 >500的人都可以完善它