Vivado - 在PlanAhead和/或Vivado中使用什么版本的TCL?

描述

PlanAhead和Vivado使用什么版本的TCL?
如何确定Vivado或PlanAhead工具使用的Tcl版本?

PlanAhead 14.x和Vivado 2012中使用的Tcl版本为8.5。

要检查任何版本中使用的Tcl版本,请使用Tcl控制台或Tcl shell中的report_environment Tcl命令,然后观察TCL_LIBRARY值。

例如,在Xilinx工具14.2 / 2012.2发行版中,report_environment命令将包含类似于以下内容的行:

TCL_LIBRARY = C:/Xilinx/14.2/ISE_DS/PlanAhead/tps/tcl/tcl8.5

有关report_environment命令和其他Tcl命令的其他详细信息,请参阅:

PlanAhead版本:

PlanAhead / Tcl命令用户指南(UG789)中提供了PlanAhead工具的特定版本的TCL文档。本文档位于:

http://www.xilinx.com/support/documentation/sw_manuals/

Vivado版本:

PlanAhead / Tcl命令用户指南(UG835)中提供了Vivado特定版本的TCL文档。本文档位于:

14.2发布: http//www.xilinx.com/support/documentation/sw_manuals/xilinx2012_2/ug835-vivado-tcl-commands.pdf

编辑 重设标签(回车键确认) 标为违禁 关闭 合并 删除

提问于 2018-07-31 14:18:40 +0800

这个帖子被标记为一个社区wiki

这个帖子是一个wiki(维基). 任何一个积分 >500的人都可以完善它