5.1i ngdBug -“FATALOLIGRATION:STATICEFILTER分析器:StasaCyrad。C:823:1.16……”

描述

关键字:NGD、Bug、5.1i、4.2i、致命、错误、静态、ACD、读取、文件、解析器、环境、变量、冲突、命令、行、路径

紧迫性:标准

一般描述:
我的系统上有多种版本的ISE工具。当我通过命令行运行NGD构建时,它的静态错误类似于:

“释放5.1.01I-NGDBudi.E.38”
版权所有(C)1995年至2001年Xilinx,公司保留所有权利。
StaseFielePalss:StasaCyrad .C:823:1.16 -ACD文件
C:/XILXX5.5.1I/AppMAM/DATAB/ACVIM.ACD>有无关数据& q v yr y z
D HB I CG:gt;在有效限定符lt;xlxv35eb 1d5121x]之后
[ 0比1P E*!KS FZJ D D M N 7O3 9?3 EZP H;?εe+b^ p
r+px{!G K''HW i&;yh & gt;过程将终止。
若要解决此错误,请查阅答案数据库和其他在线资源。HTTP://Spop.xILIXX.com."

解决方案

此错误是由环境变量指向4.2i和5.1i工具时发生的冲突引起的。这是由在“NGDBuff5.5.01I-E38”(“E38”表示4.2ISP3)的错误中的行表示的。该行应该读取“NGDBuff5.1.01i-F24”(“F24”表示5.1ISP1安装)。

若要避免此错误,请检查环境变量并删除对4.2i工具的任何引用。

当Xilinx环境变量设置为5.1i软件时,如果选择4.2i软件图标,也会发生这些错误。如果点击5.1i图标,则不会出现错误。

当环境变量被正确地设置为4.2i工具,错误消息中列出的文件引用了5.1i目录时,也看到了这个错误。如果有任何其他的Xilinx变量引用5.1i工具,它们将不得不被临时删除,以便使用4.2i工具。

例如:
Xilinx & G.C:\Base4.4.2i

XilinxayEdk&G.C:EDK

通过删除XILIXXEDK变量,可能消除了5.1i冲突。
编辑 重设标签(回车键确认) 标为违禁 关闭 合并 删除

提问于 2018-07-30 14:40:47 +0800

这个帖子被标记为一个社区wiki

这个帖子是一个wiki(维基). 任何一个积分 >500的人都可以完善它